10th May 2020

University of Texas at Arlington Outage on UTAIT

UPDATE (4pm EDT): The issue has been resolved.

UPDATE (3pm EDT): The issue has been identified, and service is being restored

We are currently investigating an outage on utait.reclaimhosting.com