5th September 2016

Minutemen Emergency maintenance on Minutemen

Update: This maintenance work has been completed.

Update: We have completed one of two required reboots. We are finishing up a few updates and will require one more reboot which will happen ASAP.

The Minutemen server will be down for a brief period of time as we do some emergency unschedule maintenance at 10PM EST. We apologize for the short notice.