22nd June 2016

Performance Issues on Several Servers

Update: Upgrades have been completed and all servers should now be operating normally.

Update: Unwound is now performing normally

Update: BHSurfers is now performing normally

Update: Hotrods is now performing normally

Update: Minutemen is now performing normally

Several of our shared hosting servers are performing upgrades to the latest version of WordPress. This may result in some performance issues on minutemen, unwound, bhsurfers, and hotrods.